I received this error recently and did some research, only to find out it was because there was a previous installation of the component.  I uninstalled the component, then reinstalled successfully.  I would have expected the common “I higher version was found” message, but did not.