SharePoint: Unfortunately, help seems to be broken

Daniel Bell's avatar
posted by
 
10/12/2017
 
23 views

A custom of ours was receiving this message when trying to access the help feature in Project Web App in a SharePoint 2016 environment. 

image

  • To troubleshoot the issue I first checked to see if the CAB files for help existed.  In a SharePoint 2016 farm they are located at, 1033 is english: C:\program Files\Common Files\microsoft shared\web server extensions\16\HCCab

Fortunately they were in place.

image

  • Next I logged on to a SharePoint farm server as a farm administrator and launched PowerShell and executed the Get-SPHelpCollection command to confirm the current status of the help files.

image

Nothing was returned, which was what I was expecting, however, it’s not what we ultimately are looking for.

  • What we want to do is install the help files with the command: Install-SPHelpCollection –help

image

  • Nothing obvious returned from the install command, however, when we run the Get-SPHelpCollection command again we see the files were installed correctly

image

Don’t be surprised if the Help does not work immediately, as it may take a few minutes for the files to completely install.

Once installed you may want to check at your site collections that the Help collections are available

  • Site Actions > Site Settings > Help Settings

image

When everything is in place accessing the Help features should work successfully!

image

image

Comments

Got something to say? Join the discussion »

leave a reply

 [Quick Submit with Ctrl+Enter]

Remember my details
Notify me of followup comments via e-mail